编号44

pycharm安装Django的问题


提问于2019-07-22 00:52    212 已解决

站长您好,我在使用pycharm安装Django时,用pip install django安装,显示错误

由于环境错误,无法安装程序包。错误:

(1,'[ssl:certificate_verify_failed]证书验证失败:证书尚未生效(_ssl.c:1056)')
在使用pip3 install django== 2.2出现错误  (因提交问题字数有限,具体版本有删除)

 找不到满足Django==要求的版本(来自版本
结果:1,
, 2.2rc1,2.2, 2.2.1, 2.2.2, 2.2.3)

rc1,No matching distribution found for django== 

使用cmd,python进行安装也是上述情况,望站长解答一下,不胜感激,谢谢您!

站长回答


这是找不到django版本的问题,你的pip比较老了吧,可以更新下pip或者
pip install git+https://github.com/django/django@c939b2a1cb22b5035b1ccf90ee7686f334e6049d#egg=django==
2.2